This project is read-only.

Deny all pages without login on Asp.net Web Forms with Identity Framework and Owin

Nov 10, 2014 at 1:52 PM
Edited Nov 10, 2014 at 1:52 PM
I have a problem with Asp.net Web Forms with Identity Framework and Owin.


Link stackoverflow

Any idea?
Nov 15, 2014 at 2:26 AM
Edited Nov 15, 2014 at 2:26 AM
I tried with the webforms application and it seems to work for below configuration in root web.config
  <system.web>
 <authorization>
      <deny users="?"/>
    </authorization>
 </system.web>
And add the following in the web.config of Account folder
  <location path="Login.aspx">
    <system.web>
      <authorization>
        <allow users="*"/>
      </authorization>
    </system.web>
   </location>
The caveat is that you have disable friendlyurls. I'll take a look at it but let me know if this temporary workaround might help you out
Dec 2, 2014 at 12:25 PM
Hi suhasj, without friendlyurls work fine.
Any news about friendlyurls ?

Thanks!
Jun 4, 2015 at 5:57 PM
Just hit the same wall, anyone found a workaround for this that doesn't involve disabling friendly URLs?
Oct 13, 2015 at 10:45 AM
HI , does anyone know if this has been logged as an issue and if it is being looked into or resolved ?

I cannot get around this and I have spent a great deal of time on working on a User Management model and then hit this as well.